php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3370 open_basedir does not work as expected
Submitted: 2000-02-01 06:23 UTC Modified: 2005-03-31 16:13 UTC
From: guenther dot mair at web dot by dot com Assigned:
Status: Wont fix Package: Other
PHP Version: 3.0.12 OS: Freebsd 3.0
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-02-01 06:23 UTC] guenther dot mair at web dot by dot com
first of all you may not use a simple ".." to indicate the parent directory. then, when using something like [open_basedir = .:../x:../y] it will work, but not only for "../x" and "../y" but also for "../z" if you try to give more than 4 parameters (this all running on freebsd 3.0) all your php3.ini settings will be droped and the default settings used.

my php3.ini file:
---------------------------------------------------------------------
safe_mode       =       On
safe_mode_exec_dir      =       /nonexistent
open_basedir    =       .:../admin:../php:../php3
upload_tmp_dir  =       ../tmp

;error_log      =       syslog
;short_open_tag =       on
---------------------------------------------------------------------

i saw configuration settings also being reset when short_open_tag was set to on.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-31 16:13 UTC] php-bugs at lists dot php dot net
We are sorry, but we do not support PHP 3 related problems anymore.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 02:01:26 2019 UTC