php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33648 Using --with-regex=system causes compile failure
Submitted: 2005-07-11 22:38 UTC Modified: 2005-07-19 16:14 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: ergin at ergin dot dyndns dot org Assigned: andrei
Status: Closed Package: Compile Failure
PHP Version: 5CVS, 4CVS (2005-07-18) OS: *
Private report: No CVE-ID:
 [2005-07-11 22:38 UTC] ergin at ergin dot dyndns dot org
Description:
------------
Got following message when I tried to build RPMS for new PHP version php-4.4.0 (OBS!!! couldn't choose it from drop menu - PHP version)

.....





Actual result:
--------------
/usr/src/redhat/BUILD/php-4.4.0/ext/standard/reg.c: In fucntion '_php_regcomp':
/usr/src/redhat/BUILD/php-4.4.0/ext/standard/reg.c:53 structure has no member named 're_magic'
/usr/src/redhat/BUILD/php-4.4.0/ext/standard/reg.c:72 structure has no member named 're_magic'
make *** [ext/standard/reg.lo] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.66063



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-07-12 08:56 UTC] ergin at ergin dot dyndns dot org
Here is my configure line...

----- START -----

%configure \
    --prefix=%{_prefix} \
    --with-config-file-path=%{_sysconfdir} \
    --enable-force-cgi-redirect \
    --disable-debug \
    --enable-pic \
    --disable-rpath \
    --enable-inline-optimization \
    --with-dom=shared \
    --with-bz2 \
    --with-db3 \
    --with-exec-dir=%{_bindir} \
    --with-freetype-dir=%{_prefix} \
    --with-gd \
    --with-gdbm \
    --with-gettext \
    --with-gmp \
    --with-jpeg-dir=%{_prefix} \
    --with-mm \
    --with-openssl \
    --with-png \
    --with-regex=system \
    --with-ttf \
    --with-xml \
    --with-expat-dir=%{_prefix} \
    --with-zlib \
    --with-layout=GNU \
    --enable-bcmath \
    --enable-debugger \
    --enable-ftp \
    --enable-magic-quotes \
    --enable-safe-mode \
    --enable-sockets \
    --enable-sysvsem \
    --enable-sysvshm \
    --enable-discard-path \
    --enable-mime-magic \
    --enable-track-vars \
    --enable-trans-sid \
 --enable-yp \
    --enable-wddx \
    --without-oci8 \
    --with-iconv --enable-mbstring --enable-mbregex \
    --with-imap=shared,/usr/local/src/imap-2002e --with-imap-ssl --with-kerberos=/usr/kerberos \
    --with-ldap=shared \
    --with-mysql=shared,/usr \
    --with-pgsql=shared \
    --with-curl=shared \
    --with-mcrypt=shared \
    --with-snmp=%{_prefix} \
    --with-snmp=shared \
    --enable-ucd-snmp-hack \
    --with-unixODBC=shared \
    --with-xmlrpc=shared \
    --with-mhash=shared \
    --enable-memory-limit \
    --enable-bcmath \
    --enable-shmop \
    --enable-versioning \
    --enable-sockets --enable-pcntl --enable-sigchild \
    $*

-------- END ----------
 [2005-07-12 15:41 UTC] tony2001@php.net
Assigned to Andrei, he broke it.

As to the problem: remove --with-regex=system from your configure line and it will work fine.
 [2005-07-15 13:03 UTC] sniper@php.net
This is not fixed yet. I added the necessary configure checks  
and now HAVE_REGEX_T_RE_MAGIC is defined if re_magic exists in regext_t struct.

Andrei: Please check it out.

 [2005-07-19 01:20 UTC] sniper@php.net
It's fixed.

 [2005-07-19 16:14 UTC] ergin at ergin dot dyndns dot org
Conifrming, it works...
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 12:01:59 2014 UTC