php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #33527 imap_open() failes to use /authuser="" option with Cyrus server
Submitted: 2005-06-30 18:44 UTC Modified: 2011-04-08 21:47 UTC
Votes:15
Avg. Score:4.3 ± 0.9
Reproduced:13 of 13 (100.0%)
Same Version:2 (15.4%)
Same OS:2 (15.4%)
From: ed2019 at columbia dot edu Assigned:
Status: Open Package: IMAP related
PHP Version: * OS: *
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-06-30 18:44 UTC] ed2019 at columbia dot edu
Description:
------------
The imap_open() function documentation displays using the authuser swich, to authenticate as the superuser but act as another user.  This option fails against Cyrus IMAP servers, even though the underlying c-client supports it.  For example:
mailutil check {servername/imap/tls/novalidate-cert/authuser="cyrus"/user="uname"}INBOX

works, but the imap_open() call to do the same thing does not.

Reproduce code:
---------------
$mbox = imap_open('{servername/imap/tls/novalidate-cert/authuser="cyrus"/user="uname"}INBOX', "cyrus","cyruspw");

Expected result:
----------------
$mbox will be a valid imap mailbox stream.

Actual result:
--------------
Nothing, then in the error log:
[client ip.ip.ip.ip] PHP Warning:  imap_open(): Couldn't open stream {mailserver/imap/tls/novalidate-cert/authuser="cyrus"/user="uname"}INBOX in /var/www/html/cyrustt/testimap.php on line 3

[client ip.ip.ip.ip] PHP Notice:  (null)(): Can't do /authuser with this server (errflg=2) in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-01 15:16 UTC] ed2019 at columbia dot edu
This is certainly a PHP bug, in the interface between php_imap and c-client.  The displayed error message 'can't do authuser with this server' is incorrect, we use the mailutil program, which does authuser, with this server.
 [2005-08-12 21:11 UTC] phantasm at wgresorts dot com
Has this been resolved yet? I have to agree with ed2019 that this is certainly a PHP bug because the mailutil works fine from the command line.
 [2008-05-22 10:03 UTC] freecityhk at hotmail dot com
still get this problem in PHP under CentOS 5
is it fixed?
 [2011-04-08 21:46 UTC] jani@php.net
-Package: Feature/Change Request +Package: IMAP related
 [2011-04-08 21:47 UTC] jani@php.net
-Operating System: RHEL4 +Operating System: * -PHP Version: 4.3.10 +PHP Version: *
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 11 22:01:32 2019 UTC