php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33499 CGI Error on using a wrong SQL Table-Name
Submitted: 2005-06-28 17:07 UTC Modified: 2005-06-28 17:46 UTC
From: master-bx at counterstrike dot de Assigned:
Status: Closed Package: SQLite related
PHP Version: 5.0.4 OS: Windows XP SP2 Professional
Private report: No CVE-ID: None
 [2005-06-28 17:07 UTC] master-bx at counterstrike dot de
Description:
------------
When sending a query to SQLite whith Table-Names that doesn't exist there is no Error Message from Php or SQLite, but CGI seems to crash and Apache shows a 500 error-page.

Reproduce code:
---------------
<?php
$query = "SELECT abcd.test FROM abcd ORDER BY ab.test";
$data = sqlite_query($con, $query);
$result = sqlite_fetch_array($data,SQLITE_ASSOC);
var_dump($result);
?>

Expected result:
----------------
any error reported by sqlite and/or php

Actual result:
--------------
cgi crashes and apache shows error-page 500

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-28 17:08 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-06-28 17:43 UTC] master-bx at counterstrike dot de
Thanks alot, the bug is fixed inside the latest snapshot.

Both Php-versions are using SQLite 2.8.14, so i think it's been a Php related bug.
 [2005-06-28 17:46 UTC] tony2001@php.net
Works fine -> closed.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 11:01:22 2020 UTC