php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33494 base64_encode
Submitted: 2005-06-27 20:20 UTC Modified: 2005-06-28 14:23 UTC
Votes:3
Avg. Score:4.0 ± 0.8
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: adax2000 at tlen dot pl Assigned:
Status: Wont fix Package: Strings related
PHP Version: 4.3.11 OS: linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-06-27 20:20 UTC] adax2000 at tlen dot pl
Description:
------------
the problem was descibed year ago in #26742 but there's no answer.

i supouse there's bug in function base64_encode 
or in file_get_contents, due to this i cannot send mail with attachments. is it possible that i have some error in configuration witch make this

Reproduce code:
---------------
echo base64_encode(file_get_contents("rys1.gif"));


Expected result:
----------------
R0lGODdhZABGAPcAAAAAAP////////////...
I get this in version 4.3.6

Actual result:
--------------
R0lGODdhZFwwRlww91wwXDBcMFwwXDD/////...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-27 20:24 UTC] tony2001@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try to avoid embedding huge scripts into the report.


 [2005-06-27 20:27 UTC] adax2000 at tlen dot pl
<?php
echo base64_encode(file_get_contents("http://lifewise.ecreative.pl/user_files/rys1.gif"));
?>
 [2005-06-27 20:32 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

I can't reproduce it neither with 4.4-dev, nor with 5.1-dev.
 [2005-06-28 02:20 UTC] adax2000 at tlen dot pl
i't is not allways posible to upgrade php i have no privileges to do this, and admin don't do this especially when you don't say that is realy bug or not. istead of this i discoverd that function file_get_contents (fread too) change every character which ord()==0 into two chr(92)+chr(48) and replace the use of this function with self-made function based on fgetc (works well)

please don't remove this reply mayby others find this usefull

p.s.
when file_get_contents use os-dependent enchanments it must not be reproducable on every host
 [2005-06-28 09:39 UTC] tony2001@php.net
I can't reproduce it on Linux, so no, it is not OS-dependant.
Also do var_dump(file_get_contents()); and figure out what is the difference between the output and the real file contents.

Feel free to reopen the report when you're able to reproduce it with latest snapshots. Thank you.
 [2005-06-28 11:51 UTC] adax2000 at tlen dot pl
i saw into source and now i know exactly what's going on. 
i wrote too allready that code 0 is replaced by 92,48 
also wenn magic_quoutes are enabled it change this string, so i'm not sure howto treat it now. surely i't should to be something about it secion of manual, that says that file_get_contents/fread are binary safe, and pear class MIME (that i use to send mails) should check this setting. 
anyway I apologize for inconvenience
 [2005-06-28 12:17 UTC] adax2000 at tlen dot pl
and the pair (that was oryginaly used in pear class MIME)
$fd = fopen("rys2.gif","rb");
$string = base64_encode(fread($fd,filesize("rys2.gif"));
realy should'n add this magic_quotos even if they are enabled at least in windows where you asure "rb" mean "read as binary"
 [2005-06-28 12:49 UTC] adax2000 at tlen dot pl
.
 [2005-06-28 14:23 UTC] tony2001@php.net
This is well documented: http://php.rinet.ru/manual/en/ref.info.php#ini.magic-quotes-runtime and there is a number of functions that you can use to change its value.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 02:01:24 2019 UTC