php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33476 relocations remain against allocatable but non-writable sections
Submitted: 2005-06-26 00:51 UTC Modified: 2005-06-26 01:54 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pavel dot stratil-jun at fenix dot cz Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 5.1.0b2 OS: Solaris 9
Private report: No CVE-ID: None
 [2005-06-26 00:51 UTC] pavel dot stratil-jun at fenix dot cz
Description:
------------
Compiling php-5.0.4 as follows goes with no problems but it fails with php-5.1.0b2.

'./configure' '--prefix=/opt/php' '--with-apxs2=/opt/apache/bin/apxs' '--with-zlib' '--with-bz2' '--enable-calendar' '--with-jpeg-dir=/usr/sfw' '--with-gd' '--with-ttf' '--enable-gd-native-ttf' '--with-mysql=/opt/mysql' '--with-db4=/usr/local/BerkeleyDB.4.1' '--with-imap=/usr/local/imap-client' '--with-imap-ssl=/usr/local/ssl' '--with-png-dir=/usr/sfw' '--with-gettext' '--with-xml=/usr/local' '--with-expat-dir=/usr/local/expat' '--with-xsl=/usr/local' '--enable-bcmath' '--with-curl=/usr/local/curl' '--with-curlwrappers' '--with-mysqli=/opt/mysql/bin/mysql_config' '--with-mcrypt=/usr/local/mcrypt' '--with-mhash=/usr/local/mhash' '--with-libxml-dir=/usr/local' '--enable-embedded-mysqli' '--enable-ipv6' '--with-iconv' '--enable-ftp' '--enable-mbstring=all' '--enable-exif' '--enable-pcntl' '--enable-sigchild' '--with-openssl'

make CFLAGS_CLEAN="-mcpu=ultrasparc -O2 -DZTS"

Actual result:
--------------
....

client.a(mx.o)
strcat                              0x10f0      /usr/local/imap-client/lib/libc-
client.a(newsrc.o)
ld: fatal: relocations remain against allocatable but non-writable sections
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-26 00:59 UTC] tony2001@php.net
The error reported somewhere in IMAP cclient libraries.
Obviously PHP bug system is not for cclient bugs on Solaris.

Feel free to reopen the report if you can prove somehow that the error is actually related to PHP itself.
 [2005-06-26 01:54 UTC] pavel dot stratil-jun at fenix dot cz
it's a fact that the c-client lib. has some issues with php, but I compiled 5.0.4 without a single problem 3 days ago on this server. since then I didnt change anything on the system. So, if it doesnt work now with 5.1b2, it seemed to me that the problem must be in php. sorry i really cant think of any different way how to prove this. if you have any suggestions let me know. Currently I use the 2001 version of the imap lib if it helps.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 18:01:23 2020 UTC