php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33470 strpos returning incorrectly on some long strings
Submitted: 2005-06-25 00:54 UTC Modified: 2005-06-25 01:41 UTC
From: phpbug at zavrazden dot borec dot cz Assigned:
Status: Not a bug Package: Strings related
PHP Version: 4.3.10 OS: Apache 2.0.54-4
Private report: No CVE-ID: None
 [2005-06-25 00:54 UTC] phpbug at zavrazden dot borec dot cz
Description:
------------
strpos returned some integer,
but haystack didnt contain needle,
integer was in mostly higher than strlen of haystack

Reproduce code:
---------------
please, look at this URL, because of big string used
as haystack I couldnt use textarea in bugreport form

http://kldr.xhosting.cz/cat_hi.php?path=./strpos failed.php

Expected result:
----------------
false

Actual result:
--------------
5225

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-25 01:02 UTC] phpbug at zavrazden dot borec dot cz
specified URL is invalid please check it here
http://kldr.xhosting.cz/strposfail.htm
 [2005-06-25 01:41 UTC] phpbug at zavrazden dot borec dot cz
sorry, its my fault ;)
string was there
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Dec 11 20:01:25 2019 UTC