php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33440 the returned image size is incorrect sometimes
Submitted: 2005-06-23 02:42 UTC Modified: 2005-06-23 11:05 UTC
From: ysu at ysumail dot com Assigned:
Status: Not a bug Package: GetImageSize related
PHP Version: 5.0.4 OS: windows XP
Private report: No CVE-ID: None
 [2005-06-23 02:42 UTC] ysu at ysumail dot com
Description:
------------
It seems this feature is not very reliable reporting the size of the image. 
The dimensions are always correct, but the physical size is sometimes reported 2 incorrectly. It happens with specific images. Here's one:
http://www.ysumail.net/test/isu1s.jpg




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-23 10:48 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-06-23 10:52 UTC] ysu at ysumail dot com
Thx I'm ok, I simply use filesize() and replaced the size value with that. It reports correct values and the other parameters are correct (width/height/type).
I just thought someone might want to take a closer look.
 [2005-06-23 10:57 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Full stop.
Since when does getimagesize() report *physical* size of the image?

 [2005-06-23 11:05 UTC] ysu at ysumail dot com
...and I'm an idiot, very sorry wasting your time. 
I can't even re-trace where did I get the notion - instead of reading the manual.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 17:01:26 2019 UTC