php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33412 Segmentation Fault when SOAP request times out
Submitted: 2005-06-20 22:13 UTC Modified: 2005-06-21 18:00 UTC
From: abertolli at innovim dot com Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.0.4 OS: Linux 2
Private report: No CVE-ID: None
 [2005-06-20 22:13 UTC] abertolli at innovim dot com
Description:
------------
When a SOAP call takes a long time to respond, the PHP client has a segmentation fault.  This is different in PHP 5.0.2 which simply returns with no results.

This is unfortunate because a seg fault terminates the entire script.

Reproduce code:
---------------
   try {
      $result = $soapclient->__soapCall($f,$p);
      print "Successful Call\n";
   } catch (SoapFault $exception) {
      print "SOAP EXCEPTION: $exception\n";
   }

Where $f and $p are the SOAP function and parameters to send.

Expected result:
----------------
Normal SOAP reponse

Actual result:
--------------
[abertolli@ssai-l1580 ISDS]$ php createMergedDataset.php
createMergedDataset : Segmentation fault


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-20 22:40 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-06-21 17:30 UTC] abertolli at innovim dot com
I am unable to reproduce the segmentation fault with the snapshot.
 [2005-06-21 18:00 UTC] sniper@php.net
Closed then.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat May 18 23:01:31 2024 UTC