php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33330 Can't connect to server,143: Error 0
Submitted: 2005-06-14 03:10 UTC Modified: 2005-06-14 04:27 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: pavel dot stratil-jun at fenix dot cz Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 5.0.4 OS: Solaris 9
Private report: No CVE-ID: None
 [2005-06-14 03:10 UTC] pavel dot stratil-jun at fenix dot cz
Description:
------------
Hi,

when trying to connect to a remote imap server (i.e. www.sendmail.cz), imap_open fails with

Can't connect to sendmail.cz,143: Error 0

- I checked remote accessibility to {www.sendmail.cz:143/imap/notls}INBOX from other people's horde/imp/test.php page
- I can connect to localhost mailboxes without problem
- I checked if firewall isn't misconfigured
- I tried different about 10 different c-client versions (2000, 2001something, 2002b, 2002d, 2002e, the newest ones, ...)
- I asked people with a working remote access from horde/imp/test.php to give me their configuration. Everything works fine for example on Debian Woody (3.0) with PHP 4.3.10 and 2002e.
- I tried using the c-client's mtest utility. mtest can connect to the given mailbox without problems, for example with 2002e.
- This problem is present since I ever tried to get remote access to imap servers. I use solaris 9 only, problem noted first with php 4.3.6, remained until now (5.0.4). Different configure lines have been used from rather basic ones to huge ones.
- I don't use the recode extension


My conclusions: a OS specific PHP bug (OS because it works on debian machines for sure, PHP because the mtest c-client utility can connect, unlike the imap_open call)

Test code comment: the server www.sendmail.cz is a freemail service provider which I chosed for tests because of remote imap accessiblility

Thanks for helping out. Am ready to reply to any questions.
Pavel S.

Reproduce code:
---------------
<?
$mbox = imap_open ("{www.sendmail.cz:143/imap/notls}INBOX", "***", "***");
echo imap_last_error();
?>

Expected result:
----------------
not an error message (= nothing)

Actual result:
--------------
Can't connect to sendmail.cz,143: Error 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-14 04:27 UTC] sniper@php.net
Works fine for me -> must be something wrong with your system.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 04:05:45 2022 UTC