php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33292 apache_get_modules() crashes
Submitted: 2005-06-10 01:07 UTC Modified: 2006-04-26 09:32 UTC
Votes:8
Avg. Score:4.1 ± 1.2
Reproduced:6 of 6 (100.0%)
Same Version:4 (66.7%)
Same OS:5 (83.3%)
From: doug_craig at charter dot net Assigned:
Status: Closed Package: Apache related
PHP Version: 5CVS-2005-06-20 OS: win32 only
Private report: No CVE-ID:
 [2005-06-10 01:07 UTC] doug_craig at charter dot net
Description:
------------
Only modification from php.ini-recommended is to enable MySQL (and changes made by PHP 5.0.4 Installer).
PHP installed as an Apache module.
Apache/1.3.33 (Win32)


Reproduce code:
---------------
<?php
print_r(apache_get_modules());
?>

Expected result:
----------------
Array
(
    [0] => core
    [1] => http_core
    [2] => mod_so
    [3] => sapi_apache2
    [4] => mod_mime
    [5] => mod_rewrite
)

Actual result:
--------------
No error report to Apache error.log

Windows error:  Apache.exe - Application Error
for a memory reference that could not be read.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-06-17 19:40 UTC] sniper@php.net
Works fine with Apache2.

 [2005-06-17 19:53 UTC] sniper@php.net
Reproduced with Apache 1.3.33

 [2005-11-25 00:56 UTC] tony2001@php.net
See also bug #29764 and this patch: http://cvs.php.net/diff.php/php-src/sapi/apache/php_apache.c?r1=1.86&r2=1.86.2.1&ty=u , which seems not to help, as the issue is reproducible in 5.0.x too.

 [2006-04-26 09:32 UTC] edink@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue May 23 12:01:36 2017 UTC