php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3306 PHP fails to parse .php3 web pages. No error messages in apache logs.
Submitted: 2000-01-24 21:34 UTC Modified: 2002-10-01 14:17 UTC
From: david at actionwebservices dot com Assigned:
Status: Wont fix Package: Reproducible Crash
PHP Version: 3.0.14 OS: Solaris 7 x86
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-01-24 21:34 UTC] david at actionwebservices dot com
PHP fails to parse .php3 web pages. No error messages in apache logs are left.  When you try to view the a .php3 page through the browser Internet Explorer just returns its standard unable to open this URL.  Php compiles with no errors or warnings with enable-track-vars and enable-mysql=/usr/local/mysql
I have tried it both with apache 1.3.9 and apache 1.3.11 and as both a statically linked module and dynamically linked.  I am sure the apache ,conf files are correct as well as the .php3 files because they are verbatim to what I was using on our BSDI 3.1 box where php was working %100.

I am submitting this as a bug becasue no one has been able to help in the php@lists.php.net.  I can not get it to dump core.  When I try using gdb I get the following messsage:

Starting program: /usr/local/httpd/bin/httpd -X -d /usr/local/httpd -f /usr/local/httpd/conf/httpd.conf
PIOCSTRACE failed: Inappropriate ioctl for device.
/proc/11763/ctl: Inappropriate ioctl for device.
procfs_read_status failed

Please help!!
Thank You

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 14:17 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 22:01:28 2019 UTC