php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33005 mysqli do not support float type
Submitted: 2005-05-11 07:58 UTC Modified: 2005-05-20 11:44 UTC
From: dan at yes dot lt Assigned: andrey (profile)
Status: Not a bug Package: MySQLi related
PHP Version: 5CVS-2005-05-19 (dev) OS: winxp
Private report: No CVE-ID: None
 [2005-05-11 07:58 UTC] dan at yes dot lt
Description:
------------
mysqli do not supports float type neither in results nor in params. for result it returns NULL instead of float, for params there is no type letter for float type...

Reproduce code:
---------------
$db = new mysqli(...);
$st = $db->prepare("SELECT 1.23 AS test");
$st->execute();
$st->store_result();
var_dump($st->num_rows);
$st->bind_result($x);
$st->fetch();
$st->free_result();
$st->close();
var_dump($x);


Expected result:
----------------
int(1)
float(1.23)

Actual result:
--------------
int(1)
NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-11 09:36 UTC] georg@php.net
Can't reproduce

Connecting to MySQL 4.1 returns
int(1)
float(1.23)

Connectiong to MySQL 5.0 returns
int(1)
string(4) "1.23"

Which MySQL client library and server do you use?
 [2005-05-11 10:52 UTC] dan at yes dot lt
PHP Version 5.0.5-dev
MySQLi Client API version  4.1.7
MySQL Server version: 5.0.4-beta
 [2005-05-12 21:33 UTC] andrey@php.net
Cannot reproduce with PHP 5.1-dev, libmysql 4.1.12 and MySQL 5.0.6-beta.

Can you try upgrading your client library? Thanks!
 [2005-05-13 11:00 UTC] dan at yes dot lt
I've tried to update libmysql to 4.1.11 and to 5.0.4-beta - this wont help... Also - where can I get the newest php_mysqli.dll ? The latest builds are going without it - may be this is a problem ?
 [2005-05-16 08:52 UTC] dan at yes dot lt
with new php_mysqli.dll script crashes near the "$st->fetch()" with any query (SELECT 1 ... , SELECT 1.23 ... , or SELECT 'x' ...).

libmysql 5.0.4-beta
 [2005-05-19 12:56 UTC] andrey@php.net
php_musqli.dll when compiled 4.1.7 headers afaik - therefore 4.1.7 libmysql.dll has to be used (afaik).
 [2005-05-19 14:53 UTC] dan at yes dot lt
with libmysql.dll v4.1.7 crashes only with float
"SELECT 1.23 ..."
 [2005-05-20 11:44 UTC] georg@php.net
When using MySQL 5 you have to also recompile php with MySQL 5 headers and libraries . As long MySQL 5 is beta we will not provide binaries which support MySQL 5.0
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 14:03:37 2021 UTC