php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32991 Error connecting to Access Database using ODBC
Submitted: 2005-05-09 21:00 UTC Modified: 2005-05-10 00:46 UTC
From: info at genitek dot net Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.3.10 OS: Win 2K Pro
Private report: No CVE-ID: None
 [2005-05-09 21:00 UTC] info at genitek dot net
Description:
------------
php.ini-dist  with register global ON
MDAC 2.8
Apache 1.3.33
PHP 4.3.10

Reproduce code:
---------------
$conn=odbc_connect("SYSTEM_DNS", "", "");
if (!$conn) { Error_handler( "Error in odbc_connect" , $conn ); }

$query="Select * from QUERY";

$result = odbc_exec($conn,$query);

if (!$result) { 
exit("Error in SQL"); } 



Expected result:
----------------
Return no error !

Actual result:
--------------
Return, ODBC error, I receive in the ODBC trace log this :

httpd           368-3ac	EXIT  SQLConnectW  with return code -1 (SQL_ERROR)
		HDBC                00A412F8
		WCHAR *             0x00A42500 [      -3] "SYSTEM_DNS\ 0"
		SWORD                       -3 
		WCHAR *             0x1F7C4AA0 [      -3] "******\ 0"
		SWORD                       -3 
		WCHAR *             0x1F7C4AA0 [      -3] "******\ 0"
		SWORD                       -3 

		DIAG [S1000] [Microsoft][Pilote ODBC Microsoft Access] Impossible d'ouvrir la base de donn?es '(Inconnu)'. Ce n'est peut-?tre pas une base de donn?es que votre application reconna?t, ou le fichier est peut-?tre endommag?. (-1028) 

And the only thing I have to do to correct the problem, RESTART APACHE.... than return or refresh the web site.. and everithing is OK for a moment... how long, I can figure...



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-09 21:02 UTC] info at genitek dot net
The error only arrive sometime, but when arrive, always stay until I restart apache. After the restart, the error disapear for a moment then, comme back
 [2005-05-10 00:46 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 13:03:35 2022 UTC