php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32884 Please add an alternate download link, like Sourceforge
Submitted: 2005-04-29 07:59 UTC Modified: 2005-04-29 09:10 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: trobinson at kgsystems dot swap-the-k-and-g dot com Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS: any
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-04-29 07:59 UTC] trobinson at kgsystems dot swap-the-k-and-g dot com
Description:
------------
Suggestion: On download pages, add an alternate link if the download does not start automatically.

When downloading anything, I often use a Windows browser to reach the download page, then copy the download link and paste it into a Linux terminal window like this:

   curl -O http://ca3.php.net/distributions/php-5.0.4.tar.bz2

However, php.net downloads reveal the true path only through an HTTP Location: redirect. If I try to curl the download link I get this:

   curl -O http://ca3.php.net/get/php-5.0.4.tar.bz2/from/this/mirror

This doesn't work, since curl doesn't follow the redirect.

Sourceforge has lots of mirrors too, but solves my problem in a simple way. After choosing a download mirror, the download page shows something linke this:

Your download should begin shortly. If it does not, try:
   http:// (link to actual download file)

The download then starts, but I cancel it.
Then I copy the above link, and paste it into my curl command.

I realize that wget would work, but curl is more basic.
I currently grab the true download path from the HTTP header, using Firefox "Live HTTP Headers".
...Tom Robinson


 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-29 09:10 UTC] derick@php.net
We will not change this - use wget as you mention, which is more clever with this and works just fine. We won't go to SourceForge way because I think that's so damned annoying (as you can't use wget there at all).
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 09:05:44 2022 UTC