php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32850 PHP crashes on startup because zend_do_implement_interface is called with NULL
Submitted: 2005-04-27 12:04 UTC Modified: 2005-05-08 23:44 UTC
From: sesser@php.net Assigned:
Status: Closed Package: SQLite related
PHP Version: 5CVS-2005-04-27 (dev) OS: Debian Sarge Unstable
Private report: No CVE-ID: None
 [2005-04-27 12:04 UTC] sesser@php.net
Description:
------------
#0  zend_hash_merge_ex (target=0x82f2d38, source=0x98, pCopyConstructor=0x81d6e10 <zval_add_ref>, size=4,
    pMergeSource=0x81c8ec0 <do_inherit_constant_check>, pParam=0x0) at /home/.../php5-200504251230/Zend/zend_hash.c:818
        p = (Bucket *) 0x82f2ca0
        t = (void *) 0x82f4908
#1  0x081c8f79 in zend_do_implement_interface (ce=0x82f2ca0, iface=0x0)
    at /home/.../php5-200504251230/Zend/zend_compile.c:2099
No locals.
#2  0x081dbfa9 in zend_class_implements (class_entry=0x82f2ca0, num_interfaces=2)
    at /home/.../php5-200504251230/Zend/zend_API.c:1646
        interface_entry = (zend_class_entry *) 0x98
        ce_num = 2
        impl_num = 2
        interface_list = 0xbffff390 "è#@ ?/@\214"
#3  0x080f6102 in zm_startup_sqlite (type=1, module_number=4) at /home/.../php5-200504251230/ext/sqlite/sqlite.c:1024
No locals.
#4  0x081daf38 in zend_register_module_ex (module=0x82f0028) at /home/.../php5-200504251230/Zend/zend_API.c:1227
        lcname = 0x0
        module_ptr = (zend_module_entry *) 0x82f0028
#5  0x081a0dc0 in php_startup_extensions (ptr=0x82a450c, count=152) at /home/.../php5-200504251230/main/main.c:1269
        end = (zend_module_entry **) 0x82a453c
#6  0x08246d2b in php_startup_internal_extensions () at main/internal_functions_cli.c:72
No locals.
#7  0x081a13ea in php_module_startup (sf=0x828396c, additional_modules=0x0, num_additional_modules=152)
    at /home/.../php5-200504251230/main/main.c:1454
        zuf = {error_function = 0x819fbb0 <php_error_cb>, printf_function = 0x819f510 <php_printf>,
  write_function = 0x81a0d70 <php_body_write_wrapper>, fopen_function = 0x81a0220 <php_fopen_wrapper_for_zend>,
  message_handler = 0x81a0340 <php_message_handler_for_zend>, block_interruptions = 0, unblock_interruptions = 0,
    get_configuration_directive = 0x81a02f0 <php_get_configuration_directive_for_zend>,
      ticks_function = 0x81abd60 <php_run_ticks>, on_timeout = 0x81a0480 <php_on_timeout>,
        stream_open_function = 0x81a0270 <php_stream_open_for_zend>, vspprintf_function = 0x81a42c0 <vspprintf>,
          getenv_function = 0x81a7620 <sapi_getenv>}
      zuv = {import_use_extension = 0x82576e6 ".php", import_use_extension_length = 136766146, html_errors = 1 '\001'}
#8  0x08245c9e in main (argc=1, argv=0xbffffbd4) at /home/.../php5-200504251230/sapi/cli/php_cli.c:632
      exit_status = 0
      c = 152
      file_handle = {type = 0 '\0', filename = 0x82a46f4 "?E*\b8n\001@л",
    opened_path = 0xbffffb28 "H????s$\b????`\234/@", handle = {fd = 134697609, fp = 0x8075289, stream = {handle = 0x8075289,
      reader = 0x402f9c50 <sys_sigabbrev+25040>, closer = 0xbffffb34, interactive = -1073743032}}, free_filename = 219 '?'}



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-28 22:00 UTC] tony2001@php.net
Any info on how to reproduce it?
 [2005-04-28 22:46 UTC] sesser@php.net
PHP crashes in the second I invoke ./php

Like the backtrace shows it dies when loading sqlite extension because it ends up calling zend_do_implement_interface (ce=0x82f2ca0, iface=0x0) <--- with a 0x0 NULL pointer


 [2005-04-29 02:25 UTC] sniper@php.net
It doesn't crash for me (either, as I guess it didn't for Antony?). So..start with the configure line you used? :)

 
 [2005-04-29 16:36 UTC] sesser@php.net
Well yeah it does not crash for me on other systems, too...

But it crashes on a more or less fresh install of Debian Sarge Unstable.

And the configure line does not matter... Same behaviour with
./configure --with-apxs=...
./configure
./configure bunch of options

I have really no clue why it dies on that one system, because I have nothing unusual on it... 

(But I will look into it again tonight...)

 [2005-05-07 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-05-08 23:44 UTC] sesser@php.net
using gawk fixes the extension load order problem
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 16:01:23 2020 UTC