php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32818 new mysqli() returns incorrect value
Submitted: 2005-04-25 05:03 UTC Modified: 2005-04-25 09:25 UTC
From: tianlin dot wang at sas dot com Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.0.4 OS: REDHAT 9
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tianlin dot wang at sas dot com
New email:
PHP Version: OS:

 

 [2005-04-25 05:03 UTC] tianlin dot wang at sas dot com
Description:
------------
$mysqli = new mysqli('host','user','password','non-exist-db') or exit('error');

does not exit the program. However, the following exits the program:

$mysqli = mysqli_connect('host','user','password','non-exist-db') or exit('error');



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-25 09:25 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 02 23:03:35 2021 UTC