php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #3276 Add PGP support
Submitted: 2000-01-22 00:54 UTC Modified: 2006-10-27 01:15 UTC
Votes:7
Avg. Score:5.0 ± 0.0
Reproduced:5 of 6 (83.3%)
Same Version:1 (20.0%)
Same OS:2 (40.0%)
From: mlemos at acm dot org Assigned: yohgaki (profile)
Status: Closed Package: Feature/Change Request
PHP Version: 4.0 OS:
Private report: No CVE-ID: None
 [2000-01-22 00:54 UTC] mlemos at acm dot org
Add at least the ability of encrypting messages with PGP using PGPlib or gnupg

PGPLib
http://www.phpi.org/sdk/

gnupg
http://www.gnupg.org/

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-02-10 13:59 UTC] jimw@php.net
refiling against 4.0.
 [2002-01-28 16:48 UTC] yohgaki@php.net
I need it too :)
Assign to me
 [2002-04-21 13:32 UTC] realmlord at hotmail dot com
Is anything happening on this? 
Gnupg at least would be nice since PGP seems to be a "frozen project" by NAI/McAffee
 [2002-04-21 14:51 UTC] wez@php.net
I looked at this recently for GPG; the links for the
application library were dead or the site was down.
You can do this stuff using popen (or the new proc_open
in the CVS version).
 [2006-10-27 01:15 UTC] magnus@php.net
See gnupg extension in PECL.

http://pecl.php.net/package/gnupg
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 06:01:26 2024 UTC