php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32715 apache can't free the memory
Submitted: 2005-04-15 12:27 UTC Modified: 2005-04-15 14:09 UTC
From: webmaster at moonnight dot org Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.0.3 OS: FreeBSD 4.10s
Private report: No CVE-ID: None
 [2005-04-15 12:27 UTC] webmaster at moonnight dot org
Description:
------------
sorry,my english is so badly.

My Webserver:
Freebsd 4.10stable
apache 2
mysql 4.1
php 5.0.3

the server as runing long time(about 1day),when the memory use very high.about 800M.
restart the apache prompt:
httpd in free(): warning: junk pointer, too high to make sense
and memory can't free.must restart system.

if abolish "LoadModule php5_module libexec/apache2/libphp5.so"
it is normal.and not this prompt.

my software is use ports install.

the php extension modules:
extension=bz2.so
extension=simplexml.so
extension=dom.so
extension=exif.so
extension=fileinfo.so
extension=filepro.so
extension=ftp.so
extension=gd.so
extension=gettext.so
extension=iconv.so
extension=mbstring.so
extension=mcrypt.so
extension=mysql.so
extension=pcre.so
extension=readline.so
extension=recode.so
extension=session.so
extension=sockets.so
extension=xml.so
extension=xmlrpc.so
extension=xsl.so
extension=zip.so
extension=zlib.so

this question is assail me a long time.
help me,please!!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-15 14:09 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 15:01:29 2024 UTC