php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32694 fsockopen timeout - solution for debian lost
Submitted: 2005-04-13 14:08 UTC Modified: 2005-04-13 17:30 UTC
From: bugs-php-net at airport1 dot de Assigned:
Status: Not a bug Package: Network related
PHP Version: 4.3.10 OS: Debian 2.4 - Apache/2.0.52
Private report: No CVE-ID: None
 [2005-04-13 14:08 UTC] bugs-php-net at airport1 dot de
Description:
------------
As stated in several bug reports there CAN be a problem with fsockopen not considering the given timeout. Especially if the connected side is down or hangs.

There seems to be a solution (having been online for a long time ago in the archived mailing lists?) for DEBIAN by recompiling PHP with special parameters OR/AND modifying (before?) a file something having to do with fcntl...

Unfortunately I have seached for the solution several hours now, but did not find it. Would be nice if someone could point me to the solution (just drop an URL?). 

Think further: This would also minimize the number of "always the same" bug report ;-)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-13 17:30 UTC] tony2001@php.net
That's not a support forum, ask about it somewhere else.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Mar 23 12:01:27 2019 UTC