php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #326 Parse Error in Operator.c???
Submitted: 1998-04-28 19:22 UTC Modified: 1998-05-04 16:54 UTC
From: djackson at cpsgroup dot com Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Release Candidate 3 OS: Red Hat 5.0
Private report: No CVE-ID: None
 [1998-04-28 19:22 UTC] djackson at cpsgroup dot com
Apache 1.2.6
  error_log
    [Tue Apr 28 15:22:00 1998] Possible PHP3 memory leak detected (harmless):  2 bytes from operators.c:683

Generated Page source:
  <HTML><HEAD><TITLE>AdServer<br>
  <b>Warning</b>:  PostgresSQL query failed:  ERROR:  parser: parse error at or near ""
   in <b>../includes/connect.inc</b> on line <b>301</b><br>
  ERROR:  parser: parse error at or near ""
This parse error is weird because this file was require()'d in the refering page and hasn't changed
and a reload works fine.

Zeev has a copy of the offending code. (Actually he has a copy of the whole site.)
And the problem is very intermittent.  If a code segment presents itself It will be provided.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-05-04 16:54 UTC] zeev
Fixed!  Yay!

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Feb 18 14:01:25 2019 UTC