php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32590 'crypt' function not available
Submitted: 2005-04-05 17:42 UTC Modified: 2005-04-06 19:01 UTC
From: webtech at get-telecom dot fr Assigned:
Status: Closed Package: *Encryption and hash functions
PHP Version: 4.3.11 OS: RedHat Entreprise 3
Private report: No CVE-ID: None
 [2005-04-05 17:42 UTC] webtech at get-telecom dot fr
Description:
------------
Hi,

I've just compiled PHP 4.3.11 (with a "make install-sapi") and there's no more crypt function.
So I decided to install back PHP 4.3.10 where crypt function is available, and it works.
Is it possible to use 'crypt' function with PHP 4.3.11 ?

Reproduce code:
---------------
$str=crypt("zzz");

Expected result:
----------------
No error.

Actual result:
--------------
Fatal error: Call to undefined function crypt() in ...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-05 17:47 UTC] tony2001@php.net
What does `./configure | grep "\<crypt\>"` say?
 [2005-04-06 17:01 UTC] webtech at get-telecom dot fr
For PHP 4.3.11, it says :
checking for crypt.h... yes
checking for crypt... no
checking for crypt.h... (cached) yes
checking for crypt... (cached) no
checking for crypt in -lcrypt... yes
checking for standard DES crypt... yes
checking for extended DES crypt... no
checking for MD5 crypt... yes
checking for Blowfish crypt... no

And for PHP 4.3.10 that have the crypt function, it says exactly the same :
checking for crypt.h... (cached) yes
checking for crypt... (cached) no
checking for crypt.h... (cached) yes
checking for crypt... (cached) no
checking for crypt in -lcrypt... (cached) yes
checking for standard DES crypt... (cached) yes
checking for extended DES crypt... (cached) no
checking for MD5 crypt... (cached) yes
checking for Blowfish crypt... (cached) no
 [2005-04-06 18:21 UTC] sniper@php.net
What configure line did you use?

 [2005-04-06 18:27 UTC] webtech at get-telecom dot fr
This one :
./configure --with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local/php-4.3.11 --with-config-file-path=/usr/local/apache/conf --with-oci8=/home/oracle/app/oracle/product/10g --disable-rpath --with-ldap --includedir=/usr/include --with-gd=/usr/local --with-freetype-dir=/usr/local --enable-gd-native-ttf --enable-gd-imgstrttf
 [2005-04-06 18:29 UTC] sniper@php.net
Is that EXACTLY same configure line you used with 4.3.10?
If you grab fresh 4.3.10 sources and compile it NOW on your system, does crypt() exist in it? (just to make sure it's not something that changed in your system)

 [2005-04-06 19:01 UTC] webtech at get-telecom dot fr
Yes, it's the same except the prefix : ./configure --with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local/php-4.3.10 --with-config-file-path=/usr/local/apache/conf --with-oci8=/home/oracle/app/oracle/product/10g --disable-rpath --with-ldap --includedir=/usr/include --with-gd=/usr/local --with-freetype-dir=/usr/local --enable-gd-native-ttf --enable-gd-imgstrttf

I don't grab fresh sources for PHP 4.3.10 cause the MD5sum is ok (73f5d1f42e34efa534a09c6091b5a21e) but I've just compiled it again, and crypt is in it...

And to be sure, i've compiled juste after with PHP 4.3.11, and it's now working with the crypt function  :-\ 
I understand nothing ! It's not a cache browser or proxy problem, but it's nether a PHP problem.
Sorry for disturbing you with this, I close the bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Mar 04 11:01:23 2021 UTC