php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32575 Accented character 'echo'ed randomly
Submitted: 2005-04-04 21:38 UTC Modified: 2005-04-05 21:02 UTC
From: john at jcoppens dot com Assigned:
Status: Not a bug Package: *Languages/Translation
PHP Version: 4.3.10 OS: linux 2.4.26
Private report: No CVE-ID: None
 [2005-04-04 21:38 UTC] john at jcoppens dot com
Description:
------------
I have a very simple web-page script with mainly 'echo' commands. Randomly the accented characters are replaced
by question-marks. If or not the question mark appears
seems to be depending on the page contents, though at least
in one of the cases, the only thing that changes in the
page is a GIF image. 

All this happens in the same html-session, using the same
script.

I've seen other -similar- reports, though none about 'echo'.
I can't be sure if this is an apache problem or php-related.

Sorry if was already solved... Please indicate.

Reproduce code:
---------------
echo "P?gina ?ndice";

Expected result:
----------------
P?gina ?ndice

Actual result:
--------------
Randomly 
P?gina ?ndice
P?gina ?ndice


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-05 01:06 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2005-04-05 21:02 UTC] john at jcoppens dot com
Thanks for the reply.

Just so other people finding this description are pointed in the correct direction, this problem appears to be a bug in Mozilla. PHP serves the accented characters correctly, the browser randomly changes them into question marks. Firefox/Opera/Dillo don't have this problem (apparently). I found this out by tracing the HTTP transfer.
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 11:01:25 2018 UTC