php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32567 Compilation fails with "make: *** [ext/gmp/gmp.lo] Error 1"
Submitted: 2005-04-04 15:23 UTC Modified: 2005-04-04 18:30 UTC
From: hipo at design dot bg Assigned:
Status: Closed Package: *Compile Issues
PHP Version: 4.3.11 OS: Fedora Core 1
Private report: No CVE-ID:
 [2005-04-04 15:23 UTC] hipo at design dot bg
Description:
------------
I'm experiencing problems during compilation time. I've made a little shell script with configure options to the php for our purposes. I succesfully compiled my php every time a new stable version comes out. Mysteriously right now i've downloaded the latest stable version and used my compilation script to compile it. And the compilation failed with ...
"/usr/local/src/php-4.3.11/ext/gmp/gmp.c: In function `convert_to_gmp':
/usr/local/src/php-4.3.11/ext/gmp/gmp.c:254: error: `tsrm_ls' undeclared (first use in this function)
/usr/local/src/php-4.3.11/ext/gmp/gmp.c:254: error: (Each undeclared identifier is reported only once
/usr/local/src/php-4.3.11/ext/gmp/gmp.c:254: error: for each function it appears in.)
make: *** [ext/gmp/gmp.lo] Error 1"

I've googled a little and found a similar bur report for on of the development php versions. It was written that the "--disable-rpath" option caused the failer. I've tried to recompile the php with no success. Configure is okay no problems are reported there but the compilation failes. Below is my configure and the options i pass to it.

#! /bin/sh
#
# Created by configure

'./configure' \
'--host=i386-redhat-linux' \
'--build=i386-redhat-linux' \
'--target=i386-redhat-linux-gnu' \
'--program-prefix=' \
'--prefix=/usr' \
'--with-dom' \
'--exec-prefix=/usr' \
'--bindir=/usr/bin' \
'--sbindir=/usr/sbin' \
'--sysconfdir=/etc' \
'--datadir=/usr/share' \
'--includedir=/usr/include' \
'--libdir=/usr/lib' \
'--libexecdir=/usr/libexec' \
'--localstatedir=/var' \
'--sharedstatedir=/usr/com' \
'--mandir=/usr/share/man' \
'--infodir=/usr/share/info' \
'--cache-file=../config.cache' \
'--with-apxs2=/usr/local/apache2/sbin/apxs' \
'--disable-static' \
'--enable-dbase' \
'--enable-ctype' \
'--enable-sysvsem' \
'--enable-sysvshm' \
'--with-tsrm-pthreads' \
'--enable-ftp' \
'--with-config-file-path=/etc' \
'--with-config-file-scan-dir=/etc/php.d' \
'--enable-force-cgi-redirect' \
'--disable-debug' \
'--enable-pic' \
'--enable-inline-optimization' \
'--with-curl' \
'--with-dom=/usr' \
'--with-exec-dir=/usr/bin' \
'--with-ttf' \
'--with-gdbm' \
'--with-gettext' \
'--with-ncurses' \
'--with-gmp' \
'--with-iconv=/usr/local/lib' \
'--with-openssl' \
'--with-regex=system' \
'--with-xml' \
'--with-expat-dir=/usr' \
'--with-layout=GNU' \
'--enable-bcmath' \
'--enable-exif' \
'--enable-magic-quotes' \
'--enable-safe-mode' \
'--enable-safe-mode' \
'--enable-sockets' \
'--enable-discard-path' \
'--enable-track-vars' \
'--enable-trans-sid' \
'--enable-wddx' \
'--with-dom' \
'--without-oci8' \
'--with-pear=/usr/share/pear' \
'--with-kerberos=/usr/kerberos' \
'--with-ldap=shared' \
'--with-mysql=/usr/local/mysql' \
'--enable-memory-limit' \
'--enable-shmop' \
'--enable-versioning' \
'--enable-calendar' \
'--enable-dbx' \
'--enable-dio' \
'--enable-mcal' \
'--enable-force-cgi-redirect' \
'--with-gd' \
'--with-zlib' \
'--with-png' \
'--enable-gd-imgstrttf' \
'--enable-gd-native-ttf' \
'--with-freetype-dir=/usr' \
'--enable-xslt' \
'--with-sablot' \
'--with-xslt-sablot' \
'--with-sablot-js=/usr/bin' \
'--disable-rpath' \
"$@"
.

I've got the same failer on one of our other servers when compiling. With different configure options.

Hope someone will find a solution for me. Thank you.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-04 16:43 UTC] edink@php.net
Which MPM is your Apache2 compiled with? Its a very bad idea to use worker MPM with PHP. Using prefork MPM will produce much more stable system.

The error message that you are seeing idicates the php is being compiled in thread safe mode.
 [2005-04-04 16:53 UTC] hipo at design dot bg
The version coming with the latest stable apache 2.0.53.
Worker MPM work perfectly with php. I'm using it on all of our servers and no problem with php 4.3.10. and versions below that are stable. I don't think the problem is concerned to MPM at all... Anyway thanks for your reply.
 [2005-04-04 16:58 UTC] tony2001@php.net
Try to execute `make clean` and to run configure && make again.
 [2005-04-04 17:01 UTC] hipo at design dot bg
Already tried that. No luck.
 [2005-04-04 18:30 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 18:01:53 2014 UTC