php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32560 configure uses incorrect libdb2.so for test
Submitted: 2005-04-04 03:43 UTC Modified: 2005-04-04 12:52 UTC
From: avanchura at comcast dot net Assigned: tony2001
Status: Closed Package: Compile Failure
PHP Version: 5.* OS: *
Private report: No CVE-ID:
 [2005-04-04 03:43 UTC] avanchura at comcast dot net
Description:
------------
the configure command uses a test locate the db2 library
but uses the incorrect name. ( db2v8 )

this worked fine on 5.0.3 but not on 5.0.4

configure test uses libdb2.so
the correct library name is libdb2.a

./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-ftp --with-ibm-db2=/home/dbinst/sqllib/ --enable-sockets --disable-libxml



Actual result:
--------------
i modified the configure command to use the correct library name and it then worked fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-04 09:16 UTC] sniper@php.net
tony2001: You propably have this stuff installed so I'll leave it to you to fix. It might be better idea to remove any filesystem checks for file existance and rather use the PHP_TEST_BUILD() macro.. 
 [2005-04-04 12:52 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 21:01:55 2014 UTC