php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32557 Still Mysql's CharSet Error
Submitted: 2005-04-03 17:08 UTC Modified: 2005-04-03 18:05 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: sun_yc at 163 dot net Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.11 OS: windows
Private report: No CVE-ID: None
 [2005-04-03 17:08 UTC] sun_yc at 163 dot net
Description:
------------
Bug #22083 php-cli MySQL charset problem 
It still exist. since Mysql goes to 4.1. When I set utf-8 to be default charset in Mysql installation.
it is showed in apache's log
File 'c:\mysql\\share\charsets\?.conf' not found (Errcode: 2)
Character set '#33' is not a compiled character set and is not specified
in the 'c:\mysql\\share\charsets\Index' file

Reproduce code:
---------------
@mysql_connect("localhost","root","123");

Expected result:
----------------
nothing

Actual result:
--------------
nothing

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-03 17:13 UTC] sun_yc at 163 dot net
Note that the two backslash does not exist,sorry.

Bug #22083 php-cli MySQL charset problem 
It still exist. since Mysql goes to 4.1. When I set utf-8 to be default charset in Mysql installation.
it is showed in apache's log
File 'c:\mysql\share\charsets\?.conf' not found (Errcode: 2)
Character set '#33' is not a compiled character set and is not specified
in the 'c:\mysql\share\charsets\Index' file
 [2005-04-03 18:05 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 08:04:05 2022 UTC