php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32553 PHP_STREAM_COPY_ALL set to 2000000
Submitted: 2005-04-03 01:49 UTC Modified: 2005-04-06 16:48 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:0 (0.0%)
From: ppmm at wuxinan dot net Assigned: iliaa
Status: Closed Package: Filesystem function related
PHP Version: 5.0.4 OS: Windows XP
Private report: No CVE-ID:
 [2005-04-03 01:49 UTC] ppmm at wuxinan dot net
Description:
------------
I noticed this is already discussed in PHP-DEV mailing list.
But I want to address it here since this is critical.
Many file related functions are affected in php 5.0.4
They stop reading at 2,000,000 bytes.
Examples are readfile() and fpassthru().
This is due to this change:

RCS file: /repository/php-src/main/php_streams.h,v
retrieving revision 1.95
retrieving revision 1.95.2.1

I wouldn't recommend upgrading from 5.0.3 to 5.0.4 if you are unsure about this issue...

[ref: 
Re: [PHP-DEV] Two minor issues in 5.0.4
Antony Dovgal
Sun, 27 Mar 2005 03:56:27 -0800
]


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-06 16:48 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 09:02:28 2014 UTC