php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32519 cli segv with https wrapper
Submitted: 2005-03-31 17:53 UTC Modified: 2005-03-31 20:33 UTC
From: mark at everytruckjob dot com Assigned:
Status: Not a bug Package: Verisign Payflow Pro related
PHP Version: 5CVS-2005-03-31 (dev) OS: slackware 10.1 glibc 2.3.4
Private report: No CVE-ID: None
 [2005-03-31 17:53 UTC] mark at everytruckjob dot com
Description:
------------
The reproducable code worked using cli with php 5.0.3 but causes a segmentation fault with 5.0.4 and php5-200503311430.

The http wrapper still works fine.

The same code works under apache2 with all versions.

I recompiled php 5.0.4 without the pfpro extension (the backtrace made me want to try this) and no segfault occured, so maybe some changes with the https wrapper is conflicting with the pfpro extension (which hasn't had any changes committed in 10 months)?


Reproduce code:
---------------
$contents = file_get_contents("https://www.glo-bus.com/");

// OR
$contents = file("https://www.glo-bus.com/");

Expected result:
----------------
$contents would contain the contents of the url requested.

Actual result:
--------------
php 5.0.4 backtrace:
http://www.tuscaloosadesigncompany.com/php-5.0.4-bt.txt

php5-200503311430 backtrace:
http://www.tuscaloosadesigncompany.com/php5-200503311430.bt.txt




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-31 20:33 UTC] sniper@php.net
RTFM: http://www.php.net/pfpro

Not PHP bug.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 00:01:23 2020 UTC