php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32369 configure: error: libjpeg.(a|so) not found
Submitted: 2005-03-19 00:18 UTC Modified: 2005-03-19 00:27 UTC
Votes:22
Avg. Score:4.5 ± 1.1
Reproduced:19 of 19 (100.0%)
Same Version:11 (57.9%)
Same OS:1 (5.3%)
From: ian_real at dominios dot net Assigned:
Status: Wont fix Package: *General Issues
PHP Version: 4.3.10 OS: Suse 9.2 2.6.8-24-smp x86_64
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-03-19 00:18 UTC] ian_real at dominios dot net
Description:
------------
configure wont find the jpeg libraries in /usr/lib64

CFLAGS="-O3 -march=nocona" CXX=gcc CXXFLAGS="-O3 -march=nocona" \
./configure --with-_lib=lib64 --libdir=/usr/lib64 --enable-cli \
--with-apxs=/usr/local/etc/httpd/bin/apxs \
--enable-xslt --with-xslt-sablot --with-bz2 \
--enable-sockets  --with-curl=/usr/local --with-dbase \
--disable-short-tags --enable-track-vars --with-gd \
--with-zlib --with-png-dir=/usr --with-jpeg-dir=/usr \
--enable-sysvshm --enable-sysvsem --disable-debug \
--enable-magic-quotes --enable-memory-limit \
--with-config-file-path=/usr/local/lib --with-mysql=/usr/local/mysql/

...

configure: error: libjpeg.(a|so) not found




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-19 00:27 UTC] sniper@php.net
This is fixed in HEAD. (upcoming PHP 5.1)
Won't fix in PHP 4.3 or PHP 5.0 branches.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun May 31 01:01:25 2020 UTC