php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32338 'UTF-8' badly supported by html_entity_decode ()
Submitted: 2005-03-16 16:17 UTC Modified: 2005-03-25 01:47 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: webmaster at reddi dot de Assigned:
Status: No Feedback Package: Strings related
PHP Version: 5.0.3 OS: Linux infong 2.4
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-03-16 16:17 UTC] webmaster at reddi dot de
Description:
------------
Where 
html_entity_decode ( 'ƒ', ENT_NOQUOTES, 'ISO-8859-1') 
yields the expected result,


html_entity_decode ( 'ƒ', ENT_NOQUOTES, 'UTF-8') 

does NOT.

Reproduce code:
---------------
<?= html_entity_decode ( '&fnof;', ENT_NOQUOTES, 'UTF-8') ; ?>


Expected result:
----------------
?

/* which is 402	0192	LATIN SMALL LETTER F WITH HOOK   (entity name is &fnof;) */

Actual result:
--------------
&#400;

/* which is 400	0190	LATIN CAPITAL LETTER OPEN E */

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-18 19:22 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.0-win32-latest.zip


 [2005-03-25 01:47 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2011-05-10 12:18 UTC] xcoureau at ekino dot com
Bug still existing. Tested using 5.3.6 and 5.3.3-7
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 05:03:12 2021 UTC