php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32326 HTTP header are checked case-sensitive, causing interoperability problems.
Submitted: 2005-03-15 21:30 UTC Modified: 2005-03-16 21:31 UTC
From: wolfgang dot glas at ev-i dot at Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.0.3 OS: SuSE-9.2
Private report: No CVE-ID: None
 [2005-03-15 21:30 UTC] wolfgang dot glas at ev-i dot at
Description:
------------
Using the SOAPClient in php-5.0.3 together with   
mono-xsp as WebService provider, I get:  
  
 Fatal error: Uncaught SoapFault exception: [HTTP] Error  
Fetching http body, No Content-Length, connection closed or  
chunked data in /home/wglas/axis/php/MyService.php:5  
  
The problem is the HTTP 1.0 resp?opnse header from this  
server:   
*************   
HTTP/1.0 200 OK\r\n   
    Response Code: 200   
Server: Mono-XSP Server/1.0.6.0 Unix\r\n   
Connection: Close\r\n   
X-Powered-By: Mono\r\n   
Date: Tue, 15 Mar 2005 20:05:31 GMT\r\n   
Content-Type: text/xml; charset=utf-8\r\n   
\r\n   
**************   
   
php-5.0.3 is upset by the caitalized word 'Close' in the   
Connection header. Changing the strncmp() call in line 854   
of php-5.0.3/ext/soap/php_http.c makes the whole thing   
operable again. Please check the HTTPs header 
interpretation   
code in php_http.c for more case sensitivity problems.   
   
  TIA,   
   
    Wolfgang  

Reproduce code:
---------------
?php

$client = new SoapClient("http://localhost:8080/hello.asmx?wsdl=0");

echo "count =  ".$client->SampleMethod()."\n";

?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-16 21:31 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Sep 21 21:01:25 2018 UTC