php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32313 mb_decode_mimeheader drops <> encoded parts
Submitted: 2005-03-15 11:06 UTC Modified: 2005-03-18 13:35 UTC
From: mortoray at ecircle-ag dot com Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 4.3.10 OS: Windows2000
Private report: No CVE-ID: None
 [2005-03-15 11:06 UTC] mortoray at ecircle-ag dot com
Description:
------------
mb_decode_mimeheader appears to be dropping parts of the input string if encoded in angle brackets.  

mb_encode_mimeheader also appears to drop these bracketed sections.


Reproduce code:
---------------
$text .= '=?iso-8859-1?q?this=20is=20some=20text?= <more after space>';
print( mb_decode_mimeheader( $text )  );


Expected result:
----------------
this is some text <more after space>

Actual result:
--------------
this is some text

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-16 07:09 UTC] mortoray at ecircle-ag dot com
The snapshop provided does not contain an php_mbstring.dll, and thus this function does not appear to be defined....
 [2005-03-18 01:44 UTC] moriyoshi@php.net
Probably you are trying to show the result in your 
browser. every <> and the enclosed string form a tag 
that won't be visible.
 [2005-03-18 07:32 UTC] mortoray at ecircle-ag dot com
moriyoshi is correct.  I had another case of text not showing up, but as I am unable to reproduce it again, we can assume I made a mistake.
 [2005-03-18 13:35 UTC] moriyoshi@php.net
Not a bug => bogus
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 25 04:03:37 2021 UTC