php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32258 SQLite module causes php to segfault
Submitted: 2005-03-09 22:55 UTC Modified: 2005-03-09 23:04 UTC
From: joh at deworks dot net Assigned:
Status: Closed Package: SQLite related
PHP Version: 5.1.* OS: *
Private report: No CVE-ID: None
 [2005-03-09 22:55 UTC] joh at deworks dot net
Description:
------------
The SQLite module contains code resulting in a Segmentation fault. I configured php5-200503091930 with:

./configure --prefix=/usr/local --with-apxs --with-zlib --with-bz2 --enable-ftp --with-gd --with-ttf --with-gettext --with-imap --with-ldap --with-mysql --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-readline --enable-sockets --with-kerberos --with-jpeg-dir=/usr --with-imap-ssl

Now, running the php cli results in a Segmentation fault:
$ sapi/cli/php
Segmentation fault

Backtrace:
(gdb) run
Starting program: /shared/src/php/php5-200503091930/sapi/cli/php
[Thread debugging using libthread_db enabled]
[New Thread 1081820480 (LWP 18860)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1081820480 (LWP 18860)]
zend_hash_merge_ex (target=0x832f868, source=0x98,
    pCopyConstructor=0x81e52a0 <zval_add_ref>, size=4,
    pMergeSource=0x81d7520 <do_inherit_constant_check>, pParam=0x0)
    at /shared/src/php/php5-200503091930/Zend/zend_hash.c:818
818         p = source->pListHead;
(gdb) bt
#0  zend_hash_merge_ex (target=0x832f868, source=0x98,
    pCopyConstructor=0x81e52a0 <zval_add_ref>, size=4,
    pMergeSource=0x81d7520 <do_inherit_constant_check>, pParam=0x0)
    at /shared/src/php/php5-200503091930/Zend/zend_hash.c:818
#1  0x081d75d9 in zend_do_implement_interface (ce=0x832f7d0, iface=0x0)
    at /shared/src/php/php5-200503091930/Zend/zend_compile.c:2096
#2  0x081ea429 in zend_class_implements (class_entry=0x832f7d0,
    num_interfaces=2) at /shared/src/php/php5-200503091930/Zend/zend_API.c:1650
#3  0x08105644 in zm_startup_sqlite (type=1, module_number=4)
    at /shared/src/php/php5-200503091930/ext/sqlite/sqlite.c:1018
#4  0x081e93a8 in zend_register_module_ex (module=0x832cb58)
    at /shared/src/php/php5-200503091930/Zend/zend_API.c:1227
#5  0x081af4e0 in php_startup_extensions (ptr=0x82d066c, count=152)
    at /shared/src/php/php5-200503091930/main/main.c:1267
#6  0x0825577b in php_startup_internal_extensions ()
    at main/internal_functions_cli.c:88
#7  0x081afab0 in php_module_startup (sf=0x0, additional_modules=0x0,
    num_additional_modules=152)
    at /shared/src/php/php5-200503091930/main/main.c:1450
#8  0x082546ee in main (argc=1, argv=0xbffffb04)
    at /shared/src/php/php5-200503091930/sapi/cli/php_cli.c:622



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-09 23:04 UTC] helly@php.net
This is a duplicate of #32144

Conclusion use gawk instead of awk/nawk/mawk and rebuild
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 16:01:23 2020 UTC