php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32189 mssql_query returns false
Submitted: 2005-03-04 11:20 UTC Modified: 2005-03-04 16:36 UTC
From: nramsbottom at hotmail dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 4.3.10 OS: Windows 2000/IIS5
Private report: No CVE-ID: None
 [2005-03-04 11:20 UTC] nramsbottom at hotmail dot com
Description:
------------
This is a continuation of bug 31195 <http://bugs.php.net/bug.php?id=31195>. 

This bug still occurs when using the ISAPI module under IIS5, but appears to be fixed when running the CGI version.

I am aware that this was corrected on the 20th December 2004, but only in the CGI - it occurs with the 15th December 2004 4.3.10 release and the 2nd March 2005 snapshot!

Reproduce code:
---------------
$mssql = mssql_connect( "<dbhost>", "<dblogin>", "<dbpwd>" );
mssql_select_db ("<dbname>" );
$res = mssql_query( "update cb_agent_details set username = 'neil' where agentid=1" );

if ($res === false)
{
  echo "mssql_query returned false.\n";
}
else
{
  echo "mssql_query returned true.\n";
}


Expected result:
----------------
The query should succeed and the positive message displayed.

Actual result:
--------------
This query succeeds (data is changed on the server) but the negative message is displayed.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-04 16:36 UTC] sniper@php.net
Install PHP correctly and it works. (This is fixed..)

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 15 04:01:28 2024 UTC