php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32187 php_interbase.dll missing from 5.0.3 zip distribution
Submitted: 2005-03-04 11:00 UTC Modified: 2005-03-07 17:54 UTC
From: ath at algonet dot se Assigned:
Status: Not a bug Package: InterBase related
PHP Version: 5.0.3 OS: Windows
Private report: No CVE-ID: None
 [2005-03-04 11:00 UTC] ath at algonet dot se
Description:
------------
After installing PHP 5.0.3 (Windows) from .ZIP file and verifying that command line version seems to work as expected, I change two entries in the php.ini file, i.e.

extension_dir = "d:\php\"
extension=php_interbase.dll

This leads to an error dialogue & error message:

$ php
PHP Warning:  PHP Startup: Unable to load dynamic library 'd:\php\php_interbase.dll' - The specified module could not be found.
 in Unknown on line 0

A search show that the .dll is not included in the .ZIP distribution, though the required gds32.dll can be found.
I can't find it in the PECL archive either, and just to be 100% sure I also checked that it isn't already preloaded.

The manual suggests that the module documentation should be consulted, but it only seems to suggest a recompile --with_interbase'.

Looks like the dll is missing from the 5.0.3 distribution.




  


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-04 16:53 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.0-win32-latest.zip


 [2005-03-07 10:13 UTC] abies@php.net
ext/php_interbase.dll is present in the .zip on www.php.net. Please make sure your extension_dir is set correctly.


 [2005-03-07 17:54 UTC] ath at algonet dot se
I agree -- there's something odd here. I've just redownloaded
the distribution (from the se.php.net mirror that I used before), and this time
I find an .../ext dir that contains considerably more .dll's (including the interbase one) than when I did this the first time. (As I deleted the original archive , and went for the 4.0.3 release instead, I can't repeat the problem.)

  Conclusion: any problem is most likely on my side of the net.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 00:01:23 2020 UTC