php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32179 xmlrpc_encode() Segmentation fault with recursive reference
Submitted: 2005-03-03 18:28 UTC Modified: 2005-10-04 13:27 UTC
From: spmhere1 at lenivec dot com Assigned: tony2001
Status: Closed Package: XMLRPC-EPI related
PHP Version: 5CVS, 4CVS (2005-03-09) OS: *
Private report: No CVE-ID:
 [2005-03-03 18:28 UTC] spmhere1 at lenivec dot com
Description:
------------
Following code produces segmentation fault - because of recursive reference


Reproduce code:
---------------
$data = array();
$data['a'] =& $data;
$data_xml = xmlrpc_encode($data);



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-04 13:27 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 10:03:03 2014 UTC