php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32148 php module segfaults with both xslt and ZendOptimizer loaded
Submitted: 2005-03-01 11:38 UTC Modified: 2005-03-01 13:17 UTC
From: dragun at yegon dot sk Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.3.10 OS: FreeBSD 5.3
Private report: No CVE-ID: None
 [2005-03-01 11:38 UTC] dragun at yegon dot sk
Description:
------------
PHP module causes segmentation fault when trying to start apache. This only happens if both ZendOptimizer and xslt modules are loaded in php.ini. Each one of these modules works fine if loaded without the other one.

The same happens if trying to run the cli version of php from command line with both modules loaded

[root@dw2]-[/root]# uname -rs
FreeBSD 5.3-STABLE
[root@dw2]-[/root]# php -v
PHP 4.3.10 (cli) (built: Jan  3 2005 20:58:49)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
     with Zend Extension Manager v1.0.6, Copyright (c) 2003-2004, by 
Zend Technologies
     with Zend Optimizer v2.5.7, Copyright (c) 1998-2004, by Zend 
Technologies
Segmentation fault (core dumped)
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-01 13:17 UTC] sniper@php.net
We do not fix bugs in Zend Optimizer, please go to http://www.zend.com/ for that.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Oct 29 09:02:33 2020 UTC