php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32067 DSO problems
Submitted: 2005-02-22 16:14 UTC Modified: 2005-02-28 16:59 UTC
Votes:4
Avg. Score:3.2 ± 0.4
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: j dot lammerts at chello dot nl Assigned:
Status: Wont fix Package: Apache2 related
PHP Version: 4CVS-2005-02-22 (stable) OS: AIX 5.2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2005-02-22 16:14 UTC] j dot lammerts at chello dot nl
Description:
------------
Hi,
I seem to be unable to get the latetst stable php4 to compile.
I'm using AIX 5.2 and IBM HTTPServer 2.0.47.1
If I try to configure with --apxs=/usr/IBMIHS/bin/apxs
I get the message :
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... expr: non-numeric argument
yes
Then, at the end :
WARNING: Your /usr/IBMIHS/bin/apxs script is most likely broken.

If I try to configure with --apxs2=/usr/IBMIHS/bin/apxs
I get the message:
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS... expr: non-numeric a
rgument
configure: error: You have enabled Apache 2 support while your server is Apache 1.3.  Plea
se use the appropiate switch --with-apxs (without the 2)
(although I'm using 2.0.47.1 ??)

Is this due to the fact that IBM messes around with standard Apache configs, and makes up their own apxs ?

Cheers


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-22 23:09 UTC] derick@php.net
It's most likely because their version string has a different format, please put the config.log online and provide a link to it here.
 [2005-02-27 15:51 UTC] j dot lammerts at chello dot nl
Will put up a link to this file. Please give me a bit to re-setup my webserver. Will have it ready by the end of this month.
 [2005-02-27 23:32 UTC] sniper@php.net
Just provide the output of this set of commands:

# httpd=`/usr/IBMIHS/bin/apxs -q SBINDIR`/`/usr/IBMIHS/bin/apxs -q TARGET`
# $httpd -v 2>&1 | grep version
# $httpd -v

 [2005-02-28 09:48 UTC] j dot lammerts at chello dot nl
Ok, here's the output:
(Went wrong first, because default /usr/IBMIHS/lib was not in LIBPATH environment):

fvlsaa1 /usr/IBMIHS # httpd=`/usr/IBMIHS/bin/apxs -q SBINDIR`/`/usr/IBMIHS/bin/apx>
fvlsaa1 /usr/IBMIHS # $httpd -v 2>&1 | grep version
fvlsaa1 /usr/IBMIHS # $httpd -v
exec(): 0509-036 Cannot load program /usr/IBMIHS/bin/httpd because of the following errors
:
        0509-150   Dependent module libaprutil-0.so could not be loaded.
        0509-022 Cannot load module libaprutil-0.so.
        0509-026 System error: A file or directory in the path name does not exist.
fvlsaa1 /usr/IBMIHS # export LIBPATH=$LIBPATH:/usr/IBMIHS/lib
fvlsaa1 /usr/IBMIHS # $httpd -v                              
Server version: IBM_HTTP_Server/2.0.47.1 Apache/2.0.47
Server built:   May 20 2004 17:07:49
fvlsaa1 /usr/IBMIHS # $httpd -v 2>&1 | grep version          
Server version: IBM_HTTP_Server/2.0.47.1 Apache/2.0.47


Tried configure again, with --with-apxs2, producing this result:

checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS... configure: error: Z
TS currently requires working POSIX threads. We were unable to verify that your system sup
ports Pthreads.
 [2005-02-28 13:34 UTC] sniper@php.net
Your system does not have pthreads -> ZTS only supports them.
(like the error msg says)

Get Apache2 from apache.org and compile it _without_ thread support and try again. See also:
 
  http://www.php.net/manual/en/install.unix.apache2.php

 [2005-02-28 16:59 UTC] j dot lammerts at chello dot nl
Hmm, bummer.
What if I'm bound to IBM's version of Apache2 ? I'm using IBMIHS 2.0.47.1 in a professional environment and cannot decide to switch from IHS to the original Apache2.
Same question as before: is this behaviour due to the fact that IBM messes around with the Apache sources, and does this mean that I will not be able to use PHP with IBM HTTPServer, ever ?

Thanks for the support so far.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 22:01:26 2019 UTC