|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31780 Bug same as bug-id=14245
Submitted: 2005-01-31 16:20 UTC Modified: 2005-02-04 11:34 UTC
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (100.0%)
From: bart8472 at gmail dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 2.3.x OS: Debian Sarge
Private report: No CVE-ID: None
 [2005-01-31 16:20 UTC] bart8472 at gmail dot com
I have the same error as here: 
And there is no is created. Same error on make install... everything is the same... and I even reinstalled whole debian and still I have the same error... Tried already on 4.3 stable and latest snapshot... This damn thing just doesn't compile as apache2 module!! 
What's UP :| I already spent 20 hours NON-STOP trying to resolve this problem. 

Best Regards... Bazyli

btw. I'm on apache2.
This doesn't even compile correctly if I configure just with:
./configure --with-apxs2


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-31 17:27 UTC]
What is in your .libs directory after you compile?
You may have to do a libtoolize --force
 [2005-01-31 18:21 UTC] bart8472 at gmail dot com
My .libs have 2 files and one symlink, libphp4.a, (symlink) and libphp4.aui...

What will libtoolize --force do?

I compiled php4.2.3 right now without any problems, so I assume that the problem only affects the 4.3.x
 [2005-02-04 11:34 UTC] bart8472 at gmail dot com
OK, I resolved the problem by adding these parameters to configure: --disable-cgi --enable-force-cgi-redirect 
Don't know why it worked that way, but it worked, and that's good news ;)
I hope you will fix that soon :)
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Mar 29 00:01:24 2020 UTC