php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31718 parse_url: http:///foo.com/bar?joe=1 not recognized
Submitted: 2005-01-27 11:49 UTC Modified: 2005-01-27 12:21 UTC
From: cox at idecnet dot com Assigned:
Status: Not a bug Package: URL related
PHP Version: 4.3.10 OS: Linux
Private report: No CVE-ID: None
 [2005-01-27 11:49 UTC] cox at idecnet dot com
Description:
------------
The valid url format: http:///foo.com/bar?joe=1 is not recognized.


Tomas V.V.Cox

Reproduce code:
---------------
php -r 'print_r(parse_url("http:///foo.com/bar?joe=1"));'

Expected result:
----------------
Array with the correct parts

Actual result:
--------------
Warning: parse_url(http:///foo.com/bar?joe=1): Unable to parse url in Command line code on line 1

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-27 11:55 UTC] derick@php.net
there are 3 /'s after http: ... that is obviously wrong.
 [2005-01-27 11:56 UTC] tony2001@php.net
Since when "http:///foo.com" is valid URL ?
No bug here.
 [2005-01-27 12:21 UTC] cox at idecnet dot com
Sorry I wanted to say "valid for web browsers". Mozilla does recognize the 'http:///foo.com' format, even something like 'http:////////foo.com', IE doesn't btw.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 06:03:37 2021 UTC