php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3168 cannot start apache 1.3.9 if mysql is compiled in, but can RESTART successfully
Submitted: 2000-01-10 23:56 UTC Modified: 2002-10-01 14:16 UTC
From: seth at psy dot au dot dk Assigned:
Status: Wont fix Package: Dynamic loading
PHP Version: 3.0.13 OS: Linux 2.2.10
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-01-10 23:56 UTC] seth at psy dot au dot dk
Please see Bug id #2187.  I have had identical problems as described there.
(and tried to add my comments there, but could not figure out how to do it. Sorry)

Using apache 1.3.9, linux-2.2.10, and php-3.0.13 (or php-4.0b3)

If I compile php-3.0.113 or php-4.0b3 WITHOUT mysql, then
I can repeatedly start and stop apache with no problem (with the php 
module being loaded)

If I compile mysql into the php module, then I cannot
start http.

(No errors are reported in the apache log file or on the screen.
 I have tried with apachectl, with a /etc/rc.d/init.d/http script, and with
simply httpd.  No success.
apachectl configtest and httpd -t reports that the syntax is OK)

I also discovered the "trick" reported  in Bug #2187. First comment
out the php module in the apache config file, start httpd, then uncomment 
the php module and RESTART the server.  And then it works fine,
it is possible to use the mysql database, etc., etc.  

So....everything seems to work fine....BUT, if I now STOP the
server, then it is not possible to start again...

(FWIW, I also have a 2.0.36, php-3.0.7, apache-1.3.6 machine running with mysql
with no problems for over a year. )

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-01-16 13:56 UTC] seth at psy dot au dot dk
I made some more experiments:

1.  Same problem as described above if:

(a) use 3.0.7
(b) use 3.0.14
(c) compile with only --with-mysql  (i.e., eliminate possible
interactions with other modules.)

2.  If I use apache-1.3.6  and exactly the same php module
that was not working as described above, then it DOES work.

In short, my problem seems to be some interaction between
how apache-1.3.9 starts up the dynamic loading of modules and
the php (with mysql) module, because, as mentioned already, there
is no problem to get things to work via restart, AFTER httpd 
has been started
 [2000-01-24 14:00 UTC] joey at cvs dot php dot net
What does apachectl configtest say?
 [2000-01-25 09:00 UTC] seth at psy dot au dot dk
      [2000-01-24 14:00:46] joey@cvs.php.net

           What does apachectl configtest say?

Syntax OK
 [2000-01-27 03:58 UTC] seth at psy dot au dot dk
I tried with Apache 1.3.11  -- Same problem.

Apachctl configtest shows synxtax OK

But if mysql is compiled into php-3.0.14, then Apache
will not start.

If Apache is started without the php module, then it is
possible to successfuly restart Apache with the php module.
 [2002-10-01 14:16 UTC] hholzgra@php.net
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 14:01:27 2020 UTC