php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3152 PHP crashes whenever doc_root in the php.ini file is modified.
Submitted: 2000-01-08 18:57 UTC Modified: 2000-08-15 09:38 UTC
From: csainz at miami dot edu Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 4.0 Beta 3 OS: Digital Unix
Private report: No CVE-ID: None
 [2000-01-08 18:57 UTC] csainz at miami dot edu
Digital Unix, Netscape Server, and PHP running in CGI mode.

PHP3 works fine.  I compiled PHP4 Beta 3 as a CGI with "-with-imap" and 
"-with-mysql" options,  then copied "php.ini-dist" to my /usr/local/lib/ and renamed
to php.ini.

[Everything works as expected up to this point]

Then I edit the php.ini and modify the doc_root entry to contain the directory
/u/php3 (where my php scripts are).  After making this change and trying
to execute a script,  the browser returns a "Server Error."   The Netscape 
server error logs the erroras follows:

[08/Jan/2000:18:29:28] failure: for host dial-up3.pcnet.miami.edu trying to POST
 /cgi-bin/php/webmail/login.php3, cgi-parse-output reports: the CGI program /u/c
gi-bin/php did not produce a valid header (name without value: got line "-------
--------------------------------")

If I then edit the php.ini file and delete the /u/php3 from doc_root.  Everything
works again.

Carlos.


Patches

Pull Requests

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-07-29 15:17 UTC] waldschrott@php.net
Please verify that it?s still happening using the latest version of PHP (release 4.0.1pl2 or CVS).
 [2000-08-15 09:38 UTC] waldschrott@php.net
Closed due to missing user feedback.
 
PHP Copyright © 2001-2026 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 11:00:01 2026 UTC