php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31506 Changes in PHP.ini file are not recognised
Submitted: 2005-01-12 04:16 UTC Modified: 2005-01-14 02:15 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: raminpanahi at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.3.10 OS: Windowss 2000
Private report: No CVE-ID: None
 [2005-01-12 04:16 UTC] raminpanahi at hotmail dot com
Description:
------------
I am using a Win2K with Apache 1.3.29 and PHP 4.3.10. I have my php.ini file in C:\winnt. It seems to read some of the entries in the INI file, and cannot read some others. Specifically "extension_dir" and "include_path". I am trying to set up extensions for MS SQL server 2000 functions, but since PHP does not load the extensions it cannot find the DLL's either. 
The PHP engine (or is it Apache?) seems to load the default values for certain INI entries.
I have upgraded several time until I got to this version and every time I get the same error. 
My php is installed in C:\PHP4 and extensions are in C:\PHP4\extensions .

Reproduce code:
---------------
I just used phpinfo()

Expected result:
----------------
I expect the DLL extensions be loaded when I run my PHP script.

Actual result:
--------------
Extensions are not loaded.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-12 05:19 UTC] jed@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2005-01-13 05:26 UTC] raminpanahi at hotmail dot com
Well, after a lengthy testing I found out the following facts:
In the PHP.INI file (regardless of its location) the following entries must be in this order for PHP and / or Apache to actually read them:
********************************
extension_dir = "c:\php4\extensions"
include_path = ".;c:\php4"
Windows: "C:\winnt;C:\winnt\system32"
******************************
If "windows" directive is moved above any of the other two then they revert back to the default values. If this is an expected behaviour then it should be documented. Otherwise this dependency should be removed from the source code. 
I hope this helps explain thisngs further. 
However, it still does not fix my problem with extension=php_mssql.dll which seems to be ignored. I cannot figure out why since phpinfo shows the correct directory for this dll. 
Thanks
 [2005-01-14 02:15 UTC] jed@php.net
This is still not a bug.

Please re-read the comments in php.ini, as you are using it incorrectly. Please do not reopen this ticket unless it is definitely a bug in PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 12:01:27 2024 UTC