php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31482 Crashes when calling method on COM objetct
Submitted: 2005-01-11 00:41 UTC Modified: 2005-01-13 00:58 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:2 (66.7%)
From: martin at hmailserver dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 4CVS-2005-01-10 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2005-01-11 00:41 UTC] martin at hmailserver dot com
Description:
------------
PHP 4.3.10 crashes every time I try to call an method on an COM object. Several users of "my" software has reported the same problem. When using PHP 4.3.9 or 5.0.3 it does not crash.

To confirm that it was not a bug in my code, I created a small dummy ATL server component in Visual Studio 2003 (containing almost no code) which a exposed dummy method that just created a message box. When I create an instance of it in VBA, PHP4.3.9 and PHP 5.0.3. It crashes in 4.3.10 and the latest available development build.

Reproduce code:
---------------
<?

	$app = new COM("DummyTest.Dummy");
	$app->Test();
?>

You either need to download the DummyTest ATL server from here and compile it yourself (in VS 2003)
http://www.hmailserver.com/PHPBug/DummyTest.rar

Or download the DLL and register it using regsvr32.exe
http://www.hmailserver.com/PHPBug/DummyTest.dll

Expected result:
----------------
The Test() function shows a message with the text OK. Test it in 4.3.9 or 5.0.3 to see expected result.

Actual result:
--------------
It crashes every single time I've tried it. 

On my computer, the following message is shown:
An exception 'Unhandled Win32 Exception' has occured in PHP.exe.

Couldn't find information on how to turn on backtrace in an win32 environment.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-11 04:01 UTC] wez@php.net
Still unresolved and critical for the next release.
 [2005-01-13 00:58 UTC] edink@php.net
This is a dupe of #31280. Tune in there for progres on this issue.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 13:05:54 2022 UTC