php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #3131 Errors while connecting Oracle database
Submitted: 2000-01-07 04:57 UTC Modified: 2006-08-01 23:21 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:-1 (-100.0%)
From: luvan at iname dot com Assigned:
Status: Wont fix Package: OCI8 related
PHP Version: 3.0.12 OS: Linux 2.2.5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2000-01-07 04:57 UTC] luvan at iname dot com
We are using Oracle 8.0.5 and Apache 1.3.9 and we have following problems:

1. Ocassional loss of persistent connection to Oracle database. Oracle returns ORA-01041 or ORA-03113. 

2. When using non-persistent connect, OCIlogon fails (again occasionally) with ORA-12154, IMHO as a consequence of error ORA-12545. We found out that after the first appearance of the error this webserver process (one of Apache's sons) is not able to connect anymore and only possibility to refresh the application is to kill it.
There is the file sqlnet.log in working directory with following messages:
------
Fatal NI connect error 12545, connecting to:
 (DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(COMMUNITY=tcp_hrouda_pre.world)(PROTOCOL=TCP)(Host=wwwcall)(Port=1
521)))(CONNECT_DATA=(SID=CCP)(CID=(PROGRAM=)(HOST=vl11823)(USER=nobody))))

  VERSION INFORMATION:
        TNS for Linux: Version 8.0.5.0.0 - Production
        TCP/IP NT Protocol Adapter for Linux: Version 8.0.5.0.0 - Production
  Time: 06-JAN-00 16:01:03
  Tracing not turned on.
  Tns error struct:
    nr err code: 12206
    TNS-12206: TNS:received a TNS error during navigation
    ns main err code: 12545
    TNS-12545: Connect failed because target host or object does not exist
    ns secondary err code: 12560
    nt main err code: 515
    TNS-00515: Connect failed because target host or object does not exist
    nt secondary err code: 111
    nt OS err code: 0
    nt OS err code: 0
------

The database server is on the same machine as the webserver and Oracle vars are set in Apache's environment.

We mean that both problems (1. and 2.) have the same cause (somewhere in PHP, Apache or Linux ??)

We found similar problems in:
- bug #2487
- http://www.weberdev.com/forum/read.php3?num=1&id=854&thread=854&

Appropriate files:
http://mujweb.cz/www/luvan/sqlnet.log
http://mujweb.cz/www/luvan/tnsnames_ora.txt (appr. part of tnsnames.ora)
http://mujweb.cz/www/luvan/set-out.txt (output of set called via PHP)
http://mujweb.cz/www/luvan/oci8.php (OCI itf functions from the appl)

Many thanks for helping us

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-30 09:03 UTC] sniper@php.net
We are sorry, but we can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Of course PHP 4 will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 21 09:01:23 2021 UTC