php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31289 PHP randomly crashes
Submitted: 2004-12-24 21:10 UTC Modified: 2004-12-24 22:14 UTC
From: smartychan at hotmail dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 4.3.10 OS: Windows XP Pro
Private report: No CVE-ID: None
 [2004-12-24 21:10 UTC] smartychan at hotmail dot com
Description:
------------
Hi,

This is actually a resubmission (I corrected something).
I have an Apache 2, PHP on windows XP pro.  They're all installed properly. When I run a php script that is big, it will crash. It will then display The Page Cannot be Displayed (Cannot find server or DNSError). I tried all 4.3 versions and 5.0, and all versions of apache,
and reformatted computer.  For example, when I use "include" and include a big regular html file with many words, php "flashes and refreshes",trying to load the php + included html page.  Then, it will suddenly
crash and the error will show up.  This also happens in another area, in a simple coppermine photo gallery.  When the php gallery is viewed, sometimes it will suddenly crash.  Sometimes it will not.  When it does
crash and the Page cannot be displyaed shows, I try to refresh it and still cannot view the crashed page.  So, it randomly crashes. The php usually crashes when it loads "big information-like a big html page"
(not necessarily php code). Also, PHP crashes on the big page no matter what machine I use to view it.  It will crash on the server machine itself when the php page is loaded.  I do not think it is my computer
server problem, tho.  This is my server:

Sony vaio
Pentium III 900mhz
512Ram
40GB hardrive NTFS

Could you help me with this problem?

Thanks,
Felix Chan


Reproduce code:
---------------
The URL to my php page that randomly crashes is:

http://chantown.com/fun/index.php?sm=facts

The included page within the php is :

http://chantown.com/fun/uselessfacts.htm

--
I also have a test page.  This test php page has one include function only.  It includes games.htm.
http://chantown.com/fun/abc.php
http://chantown.com/fun/games.htm

--
this is my php info page. http://chantown.com/phpinfo.php

this server should be running between 12 pm to 11 pm Central Time. 
Thanks!


Expected result:
----------------
The php pages are supposed to load correctly and include the htm files correctly.  

Actual result:
--------------
PHP page crashes, and Page Cannot be Displayed shows.  However, if I click refresh many times, the page will "eventually load".



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-24 22:14 UTC] magnus@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

NEVER submit same bug twice!
Just complete the other bugreport with the requested information.

And read: http://bugs.php.net/how-to-report.php

Dupe of bug #31275
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jun 14 13:01:30 2024 UTC