php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31262 https stream wrapper requires statically linked openssl module in php4.3
Submitted: 2004-12-23 01:09 UTC Modified: 2004-12-23 01:21 UTC
From: nick at foobar dot org Assigned:
Status: Not a bug Package: OpenSSL related
PHP Version: 4.3.10 OS: freebsd 4.x
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nick at foobar dot org
New email:
PHP Version: OS:

 

 [2004-12-23 01:09 UTC] nick at foobar dot org
Description:
------------
According to the 4.3.0 changelog:

"URL wrappers natively supports https:// URLs if you have compiled OpenSSL support into PHP (shared extension does not support this)".

This is a pain and the problem has just bitten me in the ass.  By default, freebsd (and probably other operating systems) compiles the core engine and the links other modules in as shared extensions.  This means that the default configuration on such systems does not support the https wrapper.  This makes writing portable php code extremely troublesome.

Can this be fixed so that https works with the shared openssl extension? Is the fix in php5 possible to back-port?

- thanks



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-23 01:21 UTC] nick at foobar dot org
after some more searching, this looks like a repeat of bug #29934. problem with php4 apis noted.  will hack freebsd port instead.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 12:03:34 2021 UTC