php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31132 Installing PHP 5.0.3 causes 403.9 HTTP Errors under IIS 5
Submitted: 2004-12-16 18:49 UTC Modified: 2005-03-10 01:00 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: aaron at visualprose dot com Assigned:
Status: No Feedback Package: IIS related
PHP Version: 5.0.3 OS: Windows XP Professional SP 1
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-12-16 18:49 UTC] aaron at visualprose dot com
Description:
------------
When PHP 5.0.3 is installed under IIS 5.0 on Windows XP Professional, all web pages (.html, .php, .asp, or .aspx) can only be viewed ten times before IIS reports "HTTP 403.9 - Access Forbidden: Too many users are connected".  No pages (inlcluding HTML, ASP, etc.) can be viewed once this error occurs.  IIS must be restarted (which takes approximately 5 minutes).

I have followed the steps on Microsoft's site to disable HTTP Keep-alives, and the problem persists.

Removing the script map to PHP solves the problem, which is what leads me to believe PHP is causing the problem

Reproduce code:
---------------
1) Install PHP 5.0.3 on Windows XP SP 1.
2) Load up a .html, .php, or .asp running on the web server.
3) Hit "Refresh" 10 times.
4) Note the 403.9 HTTP error appears.  Note that IIS must be restarted before access to any resource is allowed again.

Expected result:
----------------
No 403.9 error.

Actual result:
--------------
IIS continues to give the 403.9 error page until it is restarted.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-02-28 21:14 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2005-03-10 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2005-03-15 18:03 UTC] mailkabin at yahoo dot com
Can't Configure the PHP version 5.0 in Win2003 System.
..
Operation System : Windows Server 2003
IIS Ver : 6.0
Other Installed Comp: ASP / ASP .net 
.....
Problem :
   Displays the "Page Cannot be displayed Page." or "File Not Found Page."
 [2005-07-15 12:47 UTC] webwire at zonnet dot nl
I can confirm:
The problem is solved on the newest CVS version.
 [2006-02-14 00:20 UTC] phpbugs at thomasjung dot com
Running PHP 5.1.2 under both Windows XP (IIS 5.1) and Windows 2000 (IIS 5). In XP, experienced the error described below (HTTP 403.9 - Access Forbidden: Too many users ...). For both installations, the stop and start times for the WWW Service CAN be between 1 to 5 minutes (occasionally longer?) - especially shutting down takes extremely long. Sometimes, I have to restart the XP machine, because WWW Service or issadmin service do not stop.

I also turned off keep-alive and it didn't solve the problem.

The Windows 2000 installation is a production system, so switching to latest CVS build is not really any option. All this has started to happen since I moved from PHP4 to PHP5 a few weeks ago.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 22:03:34 2021 UTC