php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31099 RPC server unavailable error in COM
Submitted: 2004-12-15 17:59 UTC Modified: 2004-12-15 19:29 UTC
From: nick at wyfsd dot org Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.9 OS: Win 2k Server
Private report: No CVE-ID: None
 [2004-12-15 17:59 UTC] nick at wyfsd dot org
Description:
------------
When I try and execute my script which uses COM function to execute Word on the users computer, the following error is given:

Warning: Unable to obtain IDispatch interface for CLSID
{000209FF-0000-0000-C000-000000000046}: The RPC Server is not available. in C:\program files\apache group\apache\htdocs\naseg\meetlist.php on Line 6

Reproduce code:
---------------
$ip = $REMOTE_ADDR;	
$word=new COM("Word.Application", $ip) or die("Cannot start word for you"); 

My PHP.ini file ([com] section)

; path to a file containing GUIDs, IIDs or filenames of files with TypeLibs
;com.typelib_file = 
; allow Distributed-COM calls
com.allow_dcom = TRUE
; autoregister constants of a components typlib on com_load()
com.autoregister_typelib = true
; register constants casesensitive
com.autoregister_casesensitive = false
; show warnings on duplicate constat registrations
;com.autoregister_verbose = true


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-15 19:29 UTC] wez@php.net
You need to configure the remote machine to allow DCOM activation from your server.
This is beyond the scope of PHP and the PHP manual and is not a bug _in_ PHP.
I suggest you look up this error message in the Microsoft Knowledge base for more useful information.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 03:04:47 2023 UTC