php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30952 libpng.so.3 error after compiling php5.0.3rc1 with gd
Submitted: 2004-12-01 20:44 UTC Modified: 2004-12-03 08:57 UTC
From: iansutherland75 at gmail dot com Assigned:
Status: Not a bug Package: GD related
PHP Version: 5.0.2 OS: Fedora Core 3
Private report: No CVE-ID: None
 [2004-12-01 20:44 UTC] iansutherland75 at gmail dot com
Description:
------------
I get this error message whenever I try to start apache now that I've compiled PHP5.0.3rc1 with GD. 



quote: 
-------------------------------------------------------------------------------- 
Failed to start apache : 
Starting httpd: Syntax error on line 190 of /etc/httpd/conf/httpd.conf: 
Cannot load /usr/lib/httpd/modules/libphp5.so into server: libpng.so.3: failed to map segment from shared object: Permission denied 
[FAILED] 
-------------------------------------------------------------------------------- 



My server is Fedora core 3, and I've got libgd, libgd-devel, libgd-progs, libpng, libpng-devel, libjpeg, and libjpeg-devel all installed. 

I've confirmed that libpng.so.3 is in my /usr/lib/ folder and I even chmod'd it to 777 to make sure I had ok permissions. 




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-03 08:57 UTC] jorton@php.net
That's an SELinux labelling issue - run: 

 # fixfiles restore

or disable enforcement of the Apache/SELinux policy:

 # setsebool httpd_disable_trans 1

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jul 05 07:05:46 2022 UTC